Network Address Translation

Network Address Translation adalah standarisasi internet yang mengijinkan host di local area Network untuk menggunakan satu atau set lebih IP address untuk komunikasi internal dan satu atau set lebih IP address lainnya untuk komunikasi external, sebuah jaringan yang menggunakan NAT bisa disebut sebagai natted network, sebuah NAT membuatuhkan router agar fungsinya bisa berjalan dengan baik karena informasi IP Address yang ada di paket data akan ditulis ulang oleh router.
Ada dua tipe dari NAT :
  • Souce NAT atau srcnat. Tipe dari nat ini dilakukan pada paket data yang berasal dari nated network. Router menulis ulang IP address asal/sumber dari sebuah paket data dengan IP address public yang akan diteruskan oleh router ke jaringan luar.
  • Destination NAT atau dstnat. Tipe dari NAT ini dilakukan pada paket data yang berasal dari luar jaringan nated network. Hal ini biasa digunakan untuk membuat host yang ada di private network agar bisa diakses dari internet.
Source NAT
Penggunaan source nat biasanya dilakukan jika host yang ada di internal network ingin berkomunikasi dengan internet tapi IP address Public yang diberikan oleh ISP jumlahnya sangat sedikit, pada mikrotik agar ip public bisa digunakan oleh banyak komputer di lokal network action “masquarade” harus ditambahkan di firewall configuration. contohnya seperti dibawah :
  1. /ip firewall nat add chain=srcnat action=masquerade out-interface=Public

Destination NAT
Biasanya contoh destination nat digunakan jika server lokal diijinkan untuk bisa diakses melalui public/internet, misal saat user mengakses IP public yang kita dapatkan dari ISP misal 200.0.0.1 maka koneksi akan diarahkan langsung ke server lokal dengan IP 10.0.0.1, rulenya dibuat sebagai berikut :
  1. /ip firewall nat add chain=dstnat dst-address=200.0.0.1 action=dst-nat \
  2. to-addresses=10.0.0.1
rule dibawah ini juga dibuat agar server lokal dengan ip 10.0.0.1 bisa berkomunikasi dengan network luar
  1. /ip firewall nat add chain=srcnat src-address=10.0.0.1 action=src-nat \
  2. to-addresses=200.0.0.1

tapi jika sudah ada rule souce nat “masquarade” rule nomer dua tidak perlu lagi dibuat

1:1 mapping
Fungsi ini hampir sama dengan destination nat diatas akan tetapi actionnya menngunakan netmap, kelebihan penggunaan netmap ini adalah jika ada satu subnet ip publik yang mau dipetakan ke ip lokal bisa menggunakan cara ini contoh penggunaan kita mau memapping akses ke IP public network 100.100.100.0/24 akan di mapping ke IP network lokal 192.168.10.0/24 penulisan rulenya adalah sebagai berikut :
  1. /ip firewall nat add chain=dstnat dst-address=100.100.100.0/24 \
  2. action=netmap to-addresses=192.168.10.0/24
  3. /ip firewall nat add chain=srcnat src-address=192.168.10.0/24 \
  4. action=netmap to-addresses=100.100.100.0/24
Beberapa bisa dituliskan dengan cara berbeda tapi maksud penjelasannya adalah sama seperti rule dibawah
  1. /ip firewall nat add chain=dstnat dst-address=100.100.100.0-100.100.100.255 \
  2. action=netmap to-addresses=192.168.10.0-192.168.10.255
  3. /ip firewall nat add chain=srcnat src-address=192.168.10.0-192.168.10.255 \
  4. action=netmap to-addresses=100.100.100.0-100.100.100.255
Port mapping
Port mapping biasa digunakan jika mau mengakses server internal tapi dengan spesifik port tertentu, jadi pada penggunaannya misalkan kita punya 2 server internal yaitu web server(10.10.10.1) dan ftp server(10.10.10.2) yang dijinkan agar bisa dikases lewat public tapi kita hanya mendapatkan satu buah IP Public 100.100.100.1 nah dengan port mapping kedua server tersebut akan bisa diakses, rulenya adalah sebagai berikut :
  1. /ip firewall nat
  2. add chain=dstnat dst-address=100.100.100.1 dst-port=80 \
  3. action=dst-nat protocol=tcp to-address=10.10.10.1 to-port=80
  4. add chain=dstnat dst-address=100.100.100.1 dst-port=80 \
  5. action=dst-nat protocol=tcp to-address=10.10.10.2 to-port=21

rule diatas bisa diartikan : ketika ada koneksi masuk ke ip tujuan 100.100.100.1 TCP port 80, gunakanDST-NAT action dan redirect ke local address 10.10.10.1 di port80
jika pada rule sebelumnya belum ada rule srcnat masquarade maka wajib menuliskan rule srcnat dibawah agar server internal bisa berhubungan dengan network luar
  1. /ip firewall nat
  2. add chain=srcnat src-address=10.10.10.1 src-port=80 action=src-nat \
  3. protocol=tcp to-address=100.100.100.1 to-port=80
  4. add chain=srcnat src-address=10.10.10.2 src-port=21 action=src-nat \
  5. protocol=tcp to-address=100.100.100.1 to-port=21
sekian artikel dari saya tentang NAT dimikrotik jika ada yang mau dikomentari saya akan sangat senang sekali dan happy ngonfig :)

0 Response to "Network Address Translation"

Post a Comment

Ilmu ibarat sempax, kita harus menggunakannya, tapi tak perlu memamerkannya