Load Balancing

Tidak salah jika beranggapan bahwa menerapkan teknik load balancing pada dua jalur koneksi, maka besar bandwidth yang di dapatkan menjadi dua kali lipat dari bandwidth sebelum menggunakan load balancing. Maka perlu saya jelaskan lagi bahwa load balancing bisa menambah besar bandwidth yang diperoleh. Tetapi ada kekuranganya...mari kita bahas metode load balancing.
Metode load balancing sendiri ada 4 yang umum dipergunakan. Di antaranya: Static Route dengan Address List, Equal Cost Multi Path (ECMP), Nth, dan Per Connection Classifier (PCC). Masing-masing metode punya kelebihan, kekurangan dan karakteristiknya masing-masing. Kali ini, kita akan meluangkan waktu untuk sedikit mengenal mereka, dan mencari tahu manakah metode yang paling cocok diterapkan di jaringan anda.

1. Static route dengan Address list

Static route dengan Address list adalah metode load balancing yang mengelompokkan
suatu range IP address untuk dapat di atur untuk melewati salah satu gateway dengan menggunakan static routing. Metode ini sering di gunakan pada warnet yang membedakan PC untuk browsing dengan PC untuk Game Online. Mikrotik akan menentukan jalur gateway yang di pakai dengan membedakan src-address pada  paket data.
Kelebihan: dapat membagi jaringan dengan topologi yang sederhana, tidak ribet, dan tidak ada disconnection pada client yang disebabkan perpindahan gateway karena load balancing.
Kekurangan: Gampang terjadi overload jika yang aktif hanya client-client pada salah satu address list saja.

2. Equal Cost Multi Path (ECMP)

Equal Cost Multi Path adalah pemilihan jalur keluar secara bergantian pada gateway. Contohnya jika ada dua gateway, dia akan melewati kedua gateway tersebut dengan beban yang sama (Equal Cost) pada masing-masing gateway.
Kelebihan: Dapat membagi beban jaringan berdasarkan  perbandingan kecepatan di antara 2 ISP.
Kekurangan: Sering terjadi disconnection yang disebabkan oleh routing table yang restart secara otomatis setiap 10 menit.

3. Nth

Nth bukanlah sebuah singkatan. Melainkan sebuah bilangan integer (bilangan ke-N). Nth menggunakan algoritma round robin yang menentukan pembagian pemecahan connection yang akan di-mangle ke rute yang dibuat untuk load balancing. Pada dasarnya, koneksi yang masuk ke proses router akan menjadi satu arus yang sama. Walaupun mereka datang dari interface yang berbeda. Maka pada saat menerapkan metode Nth, tentunya akan ada batasan ke router untuk hanya memproses koneksi dari sumber tertentu saja. Ketika router telah membuat semacam antrian baru untuk batasan yang kita berikan di atas, baru proses Nth di mulai.
Kelebihan: Dapat membagi penyebaran paket data yang merata pada masing-masing gateway.
Kekurangan: Kemungkinan terjadi terputusnya koneksi yang disebabkan perpindahan gateway karena load balancing.

4. Per Connection Classifier (PCC)

Per Connection Classifier merupakan metode yang menspesifikasikan suatu paket menuju gateway suatu koneksi tertentu. PCC mengelompokkan trafik koneksi yang keluar masuk router menjadi beberapa kelompok. Pengelompokan ini bisa dibedakan berdasarkan src-address, dst-address, src-port dan dst-port. Mikrotik akan mengingat-ingat jalur gateway yang telah dilewati di awal trafik koneksi. Sehingga pada paket-paket data selanjutnya yang masih berkaitan akan dilewatkan pada jalur gateway yang sama dengan paket data sebelumnya yang sudah dikirim.
Kelebihan: Mampu menspesifikasikan gateway untuk tiap paket data yang masih berhubungan dengan data yang sebelumnya sudah dilewatkan pada salah satu gateway.
Kekurangan: Beresiko terjadi overload pada salah satu gateway yang disebabkan oleh pengaksesan situs yang sama.


nah sekarang kita bahas 1+1=2

Specifications

  • Packages required: system
  • License required: Level1
  • Submenu level: /interface bonding
  • Standards and Technologies: None
  • Hardware usage: Not significant
 buka ini saja http://wiki.mikrotik.com/wiki/Manual:Interface/Bonding

Untuk seting Load balance PCC (kelebihan:lebih stabil..dan bisa untuk failover)
/ip firewall mangle
add action=mark-connection chain=input comment="" connection-state=new \
    disabled=no in-interface=Public1 new-connection-mark=isp-1 passthrough=yes
add action=mark-connection chain=input comment="" connection-state=new \
    disabled=no in-interface=Public2 new-connection-mark=isp-2 passthrough=yes

/ip firewall mangle
add action=mark-routing chain=output comment="" connection-mark=isp-1 \
    disabled=no new-routing-mark=jalur-1 passthrough=no
add action=mark-routing chain=output comment="" connection-mark=isp-2 \
    disabled=no new-routing-mark=jalur-2 passthrough=no

/ip firewall mangle
add action=mark-connection chain=prerouting comment="" disabled=no \
    dst-address-type=!local in-interface=bridge1 new-connection-mark=\
    isp-1 passthrough=yes per-connection-classifier=both-addresses-and-ports:2/0
add action=mark-connection chain=prerouting comment="" disabled=no \
    dst-address-type=!local in-interface=bridge1 new-connection-mark=\
    isp-2 passthrough=yes per-connection-classifier=both-addresses-and-ports:2/1

/ip firewall mangle
add action=mark-routing chain=prerouting comment="" connection-mark=isp-1 \
    disabled=no in-interface=bridge1 new-routing-mark=jalur-1 passthrough=yes
add action=mark-routing chain=prerouting comment="" connection-mark=isp-2 \
    disabled=no in-interface=bridge1 new-routing-mark=jalur-2 passthrough=yes

/ip route
## Default route ke Modem Speedy 1
add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.0.1 \
    routing-mark=jalur-1

## Default route ke Modem Speedy 2
add disabled=no distance=2 dst-address=0.0.0.0/0 gateway=192.168.9.1 \
    routing-mark=jalur-2

## Pengaturan routing untuk masing-masing mark-routing beban trafik
add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.0.1
add comment="" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=192.168.9.1
jika untuk hotspotan tinggal tambahin mark conectionnya "hotspot=auth" seperti gambar dibawah ni


Dan ini setingan Saya  ga tau apa namanya intinya 1+1=2.(kekurangan: jika  buka email sering logout sendiri karena perpindahan gateway...tapi bisa diakali dengan mangle..port 443 diarahkan ke salah satu ISP)bisa utk failover
buat dulu
/ip route
add check-gateway=ping distance=1 gateway=(gateway1) routing-mark=to_PUBLIC1
add distance=2 gateway=(gateway2) routing-mark=to_PUBLIC2
add check-gateway=ping distance=1 gateway=(gateway1)
add check-gateway=ping distance=2 gateway=(gateway2)


/ip firewall mangle
add action=mark-connection chain=input comment="1+1=2" disabled=no in-interface="1public" new-connection-mark=conn-public1
add action=mark-connection chain=input in-interface="2public" new-connection-mark=conn-public2
add action=mark-routing chain=output connection-mark=Public1_conn new-routing-mark=to_PUBLIC1
add action=mark-routing chain=output connection-mark=Public2_conn new-routing-mark=to_PUBLIC2
add chain=prerouting dst-address=(publik2) in-interface="1public"
add chain=prerouting dst-address=(publik1) in-interface="2public"
add action=mark-connection chain=prerouting dst-address-type=!local in-interface=lokal new-connection-mark=Public1_conn per-connection-classifier=both-addresses-and-ports:2/0
add action=mark-connection chain=prerouting dst-address-type=!local in-interface=lokal new-connection-mark=Public2_conn per-connection-classifier=both-addresses-and-ports:2/1
add action=mark-routing chain=prerouting connection-mark=Public1_conn in-interface=bridge1 new-routing-mark=to_PUBLIC1
add action=mark-routing chain=prerouting connection-mark=Public2_conn in-interface=bridge1 new-routing-mark=to_PUBLIC2

jangan lupa NAT nya utk 2 interface public

Sebagai Contoh
/ip route
add check-gateway=ping distance=1 gateway=192.168.1.254 routing-mark=to_PUBLIC1
add distance=2 gateway=192.168.100.1 routing-mark=to_PUBLIC2
add check-gateway=ping distance=1 gateway=192.168.1.254
add check-gateway=ping distance=2 gateway=192.168.100.1

/ip firewall mangle
add action=mark-connection chain=input comment="1+1=2" disabled=no in-interface="1public" new-connection-mark=conn-public1
add action=mark-connection chain=input in-interface="2public" new-connection-mark=conn-public2 add action=mark-routing chain=output connection-mark=conn-public1 new-routing-mark=to_PUBLIC1
add action=mark-routing chain=output connection-mark=conn-public2 new-routing-mark=to_PUBLIC2
add chain=prerouting dst-address=192.168.100.1 in-interface="1public"
add chain=prerouting dst-address=192.168.1.254 in-interface="2public"
add action=mark-connection chain=prerouting dst-address-type=!local in-interface=bridge1 new-connection-mark=Public1_conn per-connection-classifier=both-addresses-and-ports:2/0
add action=mark-connection chain=prerouting dst-address-type=!local in-interface=bridge1 new-connection-mark=Public2_conn per-connection-classifier=both-addresses-and-ports:2/1 add action=mark-routing chain=prerouting connection-mark=Public1_conn in-interface=bridge1 new-routing-mark=to_PUBLIC1
add action=mark-routing chain=prerouting connection-mark=Public2_conn in-interface=bridge1 new-routing-mark=to_PUBLIC2



0 Response to "Load Balancing"

Post a Comment

Ilmu ibarat sempax, kita harus menggunakannya, tapi tak perlu memamerkannya