Setting DNS afraid Pada Mikrotik Terbaru



Berhubung kemarin setting DNS afraid pada mikrotik di salah satu warnet klien saya. Mending di dokumentasikan disini. Barang kali bisa berguna suatu saat atau sobat semua membutuhkan. Cmiw. Langsung saja… :D
  • Buka Winbox, lalu masuk System -> Scripts.
1
System -> Scripts
  • Klik Tombol + pada menu Script
2
Tekan + seperti di Panah
  • Masukkan Script seperti dibawah ini. Lalu tekan OK.
3
Script dan nama diisi Afraid.org
  • Script :
:global AfraidUser "USERNAME_DNSAFRAID"
 :global AfraidPass "PASSWORD_DNSAFRAID"
 :global WANInter "INTERFACE"
 :global AfraidDomain "ALAMAT"
:global IpCurrent [/ip address get [find interface=$WANInter] address];
 :for i from=( [:len $IpCurrent] - 1) to=0 do={
 :if ( [:pick $IpCurrent $i] = "/") do={
 :global NewIP [:pick $IpCurrent 0 $i];
 :if ([:resolve $AfraidDomain] != $NewIP) do={
 /tool fetch mode=http url="http://freedns.afraid.org/dynamic/update.php?VG02WTg2MzFVMVVBQUtjV2dPWToxMjMwNzAyMw==" keep-result=no
 :log info "Afraid.org Update: $AfraidDomain - $NewIP"
 } else={
 :log info "Afraid.org: don't need updates";
 }
 }
 }
  • Setelah diisi lalu tekan OK untuk menyimpan
  • Sobat perhatikan pada tulisan berwarna di atas, Untuk yang berwarna merah silahkan isikan username yang digunakan untuk login DNS AFRAID, Untuk yang berwarna hijau silahkan isikan password yang digunakan untuk login DNS AFRAID, Untuk yang berwarna biru silahkan diisikan nama Interface yang konek ke sumber internet atau interface yang menuju ke MikroTik, Untuk yang berwarna Pink itu merupakan alamat yang kita daftarkan pada DNSAFRAID. untuk warna orange, silahkan diisikan alamat dinamic update yang kita dapatkan dari DNSAFRAID. (untuk alamat dinamic update , silahkan login dahulu ke freedns.afraid.org. Kalau belum punya daftar terlebih dahulu. Lalu masuk menu Dynamic DNS. Ambil alamat pada Direct URL klik kanan pilih copykan alamat tautan atau copy link adress)
Langkah selanjutnya menambahkan scheduler untuk menjadwalkan mikrotik akan mengupdate ke dns afraid. Fungsinya adalah jika koneksi pada modem tidak stabil maka IP akan berganti-ganti sendiri tanpa kita ketahui. Maka script ini diberikan agar Mikrotik mengupdate IP secara berkala sesuai yang kita jadwalkan. Caranya :
  • Masuk System -> Scheduler
    4
    System -> Scheduler
  • Tekan tombol + pada Scheduller
  • 5
    System -> Scheduler
  •  Lalu setting seperti dibawah ini.
6
Setting seperti pada gambar diatas
Sobat perhatikan pada settingan Interval time seperti seperti screenshoot di atas. disitu tertuliskan start at Startup dan interval time 00:20:00 itu artinya script akan dijalankan setiap 20 menit sekali dimulai padaa saat startup. Sesuaikan saat dengan selera masing-masing.

1 Response to "Setting DNS afraid Pada Mikrotik Terbaru"

  1. http://mikrotik.co.id/artikel_lihat.php?id=89
    ato..
    # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    # EDIT KONFIGURASI SESUAI ACCOUNT ANDA
    # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    :global ddnsuser "NathanGR"
    :global ddnspass "Password"
    :global ddnshost "thinkxfree.freeddns.com"
    :global ddnsinterface "SPEEDY"
    # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    # END OF USER DEFINED CONFIGURATION
    # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    :global ddnssystem ("mt-" . [/system package get [/system package find name=system] version] )
    :global ddnsip [ /ip address get [/ip address find interface=$ddnsinterface] address ]
    :global ddnslastip
    :if ([:len [/interface find name=$ddnsinterface]] = 0 ) do={ :log info "DDNS: Gak ada interface dengan nama $ddnsinterface, check konfigurasinya lagi Mas Bro." }
    :if ([ :typeof $ddnslastip ] = "nothing" ) do={ :global ddnslastip 0.0.0.0/0 }
    :if ([ :typeof $ddnsip ] = "nothing" ) do={
    :log info ("DDNS: Gak ada IP Address di " . $ddnsinterface . ", check dong Mas Bro.")
    } else={
    :if ($ddnsip != $ddnslastip) do={
    :log info "IP Public : $ddnsip."
    :log info "DDNS: UPDATE Sukses Mas Bro!"
    :log info [ :put [/tool dns-update name=$ddnshost address=[:pick $ddnsip 0 [:find $ddnsip "/"] ] key-name=$ddnsuser key=$ddnspass ] ]
    :global ddnslastip $ddnsip
    } else={
    :log info "IP Public : $ddnsip."
    :log info "DDNS: Gak ada perubahan IP Public Mas Bro."
    }
    }

    # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    ReplyDelete

Ilmu ibarat sempax, kita harus menggunakannya, tapi tak perlu memamerkannya