WebServer tidak bisa di panggil ip publiknya melalui jaringan lokal

Saya Akan sedikit berbagi pengalaman tentang webserver yang tidak bisa di panggil melalui ip publiknya..
ketika melayani banyak klien yang ingin mengonlinkan web nya melalui server pribadinya tapi tidak bisa dipanggil nama domain dari lingkungan jaringan lokal kita ada beberapa penyebab,,...yaitu memang kebijakan dari isp ato memang kesalahan direct  dari router kita.....
angsung saja...
Topology kurang lebihnya seperti ini
Karena menggunakan system VPN(jadi user bisa internet harus login dengan vpn)maka langkah pertama kita harus bikin route untuk ruter linksys nya di Router mikrotik kita...
misal ip wan 192.168.2.2 dan ip lokal linksy 192.168.10.1/24 dan ip server 192.168.10.2/24
kita bikin ip address di ruter kita 192.168.2.1/30
kemudian bikin routenya
 /ip route
add comment=Linksys disabled=no distance=1 dst-address=192.168.10.0/24 \  gateway=192.168.2.2 scope=30 target-scope=10

setelah kita bisa ping ip server 192.168.10.2 reply maka route kita dah berhasil
lalu utk tahap selanjutnya kita bikin dstnat
/ip firewall nat
add action=dst-nat chain=dstnat dst-address=10.10.10.1 dst-port=80 \
    in-interface=PUBLIK protocol=tcp to-addresses=192.168.10.2 \
    to-ports=80

setelah kita coba panggil ip publik kita (misal 10.10.10.1) melalui jaringan internet diluar jaringan kita berhasil(saat itu penulis coba panggil ip publiknya melalui sambungan data Handphone)berarti online server kita sudah berhasil....
tapi kenapa kok tidak bisa dipanggil melalui jaringan lokal?(kalo pakai modem tp link dah ketemu masalahnya karena modul ACL di modemnya tidak diaktifkan)
tapi kalo melalui mikrotik dengan cara sbagai berikut
1.buat addres list bernama server (10.10.10.1 adalah ip publik kita)
/ip firewall address-list
add address=10.10.10.1 list=server

 kemudian bikin direct

/ip firewall nat
add action=dst-nat chain=dstnat dst-address-list=server dst-port=80 protocol=\
    tcp to-addresses=192.168.10.2 to-ports=80

itu artinya ketika panggil domain server atau ip publik kita dari jaringan lokal maka akan di direct langsung ke ip lokal server...
dan untuk merubah ip ke ddns atau menjadi alamat domain akan kita bahas dilain waktu...(karena itu merupakan tekhnik perhostingan dan webmastering...
cukup sekian catatan dari saya.....

0 Response to "WebServer tidak bisa di panggil ip publiknya melalui jaringan lokal"

Post a Comment

Ilmu ibarat sempax, kita harus menggunakannya, tapi tak perlu memamerkannya