Boongin Speedtest

Suport by: http://speedtest.hattapratama.com/
Dalam tutorial kali ini kita bahas cara manipulasi speedtest agar hasill speedtest nya extreme dan sangat mencengangkan. Tidak seperti dari proxy yg hanya download saja yg dapat dimanipulasi ini bahkan dapat memanipulasi upload serta pingnya. Ok kita mulai saja tuts nya.OS yang saya gunakan ini adalah ubuntu server 11.10, Masuk ke ubuntu melalui ssh menggunakan putty dan pastikan pada mesin ubuntu anda telah terinstal apache dan php jika belum maka instal terlebih dahulu 
sudo apt-get install apache2 php5
selanjutnya masuk kefolder file webserver
cd /var/www
dan download file speedtest
wget http://c.speedtest.net/mini/mini.zip
lalu extrak file tersebut menggunakan unzip, jika belum terinstal maka anda harus menginstalnya terlebih dahulu.
sudo apt-get install unzip
unzip mini.zip
Apabila anda menggunakan DNS SERVER UNBOUND silahkan copas baris dibawah ini dan sesusaikan ip nya dengan ip mesin ubuntu anda, letakkan diatas baris forward-zone
local-data: "speedtest.indosatm2.com 86400 IN A 192.168.88.8"
local-data: "speedtest.sby.dnet.net.id 86400 IN A 192.168.88.8"
local-data: "speedtest.biznetnetworks.com 86400 IN A 192.168.88.8"
local-data: "jogja.speedtest.telkomspeedy.com 86400 IN A 192.168.88.8"
local-data: "www.speedtest.mygreenlinks.net 86400 IN A 192.168.88.8"
local-data: "speedtest.sby.dnet.net.id 86400 IN A 192.168.88.8"
local-data: "1.speedtest.telkomspeedy.com 86400 IN A 192.168.88.8"
local-data: "2.speedtest.telkomspeedy.com 86400 IN A 192.168.88.8"
local-data: "3.speedtest.telkomspeedy.com 86400 IN A 192.168.88.8"
local-data: "4.speedtest.telkomspeedy.com 86400 IN A 192.168.88.8"
local-data: "5.speedtest.telkomspeedy.com 86400 IN A 192.168.88.8"
local-data: "6.speedtest.telkomspeedy.com 86400 IN A 192.168.88.8"
local-data: "7.speedtest.telkomspeedy.com 86400 IN A 192.168.88.8"
local-data: "8.speedtest.telkomspeedy.com 86400 IN A 192.168.88.8"
local-data: "9.speedtest.telkomspeedy.com 86400 IN A 192.168.88.8"
local-data: "10.speedtest.telkomspeedy.com 86400 IN A 192.168.88.8"
local-data: "speedtest.elnus.net.id 86400 IN A 192.168.88.8"
local-data: "speedtest.wigo.co.id 86400 IN A 192.168.88.8"
local-data: "speedtest-surabaya.biznetnetworks.com 86400 IN A 192.168.88.8"
local-data: "speedtest.cbn.net.id 86400 IN A 192.168.88.8"
local-data: "speedtest.vqbn.com 86400 IN A 192.168.88.8"
local-data: "speedtest.singnet.com.sg 86400 IN A 192.168.88.8"
Dan restart DNS server anda
sudo service unbound restart
Bagi yang menggunakan DNS servernya Mikrotik silahkan copas baris dibawah di terminal jangan lupa untuk menyesuaikan ip nya sesuai dengan ip mesin ubuntu anda.
ip dns static add address=192.168.88.8 ttl=1d name="speedtest.indosatm2.com"
ip dns static add address=192.168.88.8 ttl=1d name="speedtest.sby.dnet.net.id"
ip dns static add address=192.168.88.8 ttl=1d name="speedtest.biznetnetworks.com"
ip dns static add address=192.168.88.8 ttl=1d name="jogja.speedtest.telkomspeedy.com"
ip dns static add address=192.168.88.8 ttl=1d name="www.speedtest.mygreenlinks.net"
ip dns static add address=192.168.88.8 ttl=1d name="speedtest.sby.dnet.net.id"
ip dns static add address=192.168.88.8 ttl=1d name="1.speedtest.telkomspeedy.com"
ip dns static add address=192.168.88.8 ttl=1d name="2.speedtest.telkomspeedy.com"
ip dns static add address=192.168.88.8 ttl=1d name="3.speedtest.telkomspeedy.com"
ip dns static add address=192.168.88.8 ttl=1d name="4.speedtest.telkomspeedy.com"
ip dns static add address=192.168.88.8 ttl=1d name="5.speedtest.telkomspeedy.com"
ip dns static add address=192.168.88.8 ttl=1d name="6.speedtest.telkomspeedy.com"
ip dns static add address=192.168.88.8 ttl=1d name="7.speedtest.telkomspeedy.com"
ip dns static add address=192.168.88.8 ttl=1d name="8.speedtest.telkomspeedy.com"
ip dns static add address=192.168.88.8 ttl=1d name="9.speedtest.telkomspeedy.com"
ip dns static add address=192.168.88.8 ttl=1d name="10.speedtest.telkomspeedy.com"
ip dns static add address=192.168.88.8 ttl=1d name="speedtest.elnus.net.id"
ip dns static add address=192.168.88.8 ttl=1d name="speedtest.wigo.co.id"
ip dns static add address=192.168.88.8 ttl=1d name="speedtest-surabaya.biznetnetworks.com"
ip dns static add address=192.168.88.8 ttl=1d name="speedtest.cbn.net.id"
ip dns static add address=192.168.88.8 ttl=1d name="speedtest.vqbn.com"
ip dns static add address=192.168.88.8 ttl=1d name="speedtest.singnet.com.sg"
Dan yang terakhir buatlah mangle di mikrotik dan letakkan pada baris paling atas agar speedtest tidak terlimit oleh mikrotik.
/ip firewall mangle>
add chain=prerouting action=mark-packet new-packet-mark=speedtest passthrough=no protocol=tcp src-address=192.168.88.8 src-port=80
add chain=prerouting action=mark-packet new-packet-mark=speedtest passthrough=no protocol=tcp dst-address=192.168.88.8 dst-port=80
Untuk queue disini saya menggunakan queue tree
/queue tree
add name="speedtest" parent=global-total packet-mark=speedtest limit-at=0 queue=default priority=2 max-limit=0 burst-limit=0 burst-threshold=0 burst-time=0s
Cobalah untuk mengakses speedtest.net dan lakukan speedtest


0 Response to "Boongin Speedtest"

Post a Comment

Ilmu ibarat sempax, kita harus menggunakannya, tapi tak perlu memamerkannya